Resolved Saturday 2nd April 2022 03:57:00 UTC


Resolved - April 02, 2022 13:23:47 UTC


IdenTrust Public Issuance check failed @ April 02, 2022 03:57:01 UTC

This has been resolved - during this time IdenTrust was suffering from a partial outage of their REST API. Approximately 50% of all issuance requests were failing where a 404 HTML page was returned instead of a JSON response.