Resolved Saturday 2nd April 2022 17:13:00 UTC


Resolved - April 02, 2022 18:07:35 UTC


IdenTrust Public Issuance check failed @ April 02, 2022 17:13:46 UTC

This has been resolved - during this time IdenTrust was suffering from a partial outage of their REST API. Approximately 91% of all issuance requests were failing where a 500 Internal Server Error returned instead of a JSON response.